User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3338
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Russound CAV66 and recent updates

Sat Jun 24, 2017 2:53 pm

Dave P - Everything was great until this morning when my Russound will not switch sources. I noticed a barrage of updates this week while I was gone. Is there anything that may have effected commands from the Sources/Zones getting to the Russound? I have zone on/off and volume control but no switching control. I do not see that the Russound driver is receiving a source switch command from the Russound log.

Let me know what the steps should be. My scripts are custom to include the Polk XM receiver. I can delete them and start over, but is a large PIA to rebuild the customs for the POLK.

Unrelated, but maybe related, another issue I discovered this week among the rain drops; The irrigation auto start is not working. I can run zones and programs manually, but they will not auto start. The log thinks that the zones are running. HAI never sees the command to start. Probably something to do with the HAI update, but can you look into it. I will post this in the appropriate area but this functionality stopped last Monday or so.

I have not touched the system in two months, so both issues must be related to Auto-Updates. When will I learn to not auto update!
Thanks
Dave Bruner
:shock:

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3338
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Re: Russound CAV66 and recent updates

Sun Jun 25, 2017 10:47 am

Dave - First - Irrigation is working after a re-initialization of HAI. That is off the list.

The Russound driver update from 6/20/17 broke the ability to switch sources. All other functionality seems to work. See the log below;

Edit: I just rolled the driver back from my backup and all works, so there is something up with the current release

6/25/2017 10:51:46 AM ProcessCommand Cmd=[1~SetSource~5~2] Client=[MyClient]
6/25/2017 10:51:46 AM TX:1 F0 00 00 7F 00 04 70 05 02 00 00 00 F1 3E 00 00 00 01 00 01 2F F7
6/25/2017 10:51:46 AM TX:1 F0 00 00 7F 00 04 70 05 02 00 00 00 F1 3E 00 00 00 01 00 01 2F F7
6/25/2017 10:51:46 AM ProcessResponse Display Message [F0 00 04 7D 00 00 7F 06 5A 01 00 00 05 63 F7]
6/25/2017 10:51:46 AM ProcessResponse Unknown Source Name Message Value [5A]
6/25/2017 10:51:46 AM ProcessResponse Unknown #1
6/25/2017 10:51:46 AM MacroExists Looking for Russound.Source.Changed
6/25/2017 10:51:46 AM ProcessResponse Display Message [F0 00 04 7D 00 00 7F 06 5A 01 00 00 05 63 F7]
6/25/2017 10:51:46 AM ProcessResponse Unknown Source Name Message Value [5A]
6/25/2017 10:51:46 AM ProcessResponse Unknown #1
6/25/2017 10:51:46 AM MacroExists Looking for Russound.Source.Changed
6/25/2017 10:51:57 AM ProcessCommand Cmd=[1~Status~1] Client=[]
6/25/2017 10:51:57 AM TX:1 F0 00 00 7F 00 00 70 01 04 02 00 00 07 00 00 7C F7
6/25/2017 10:51:58 AM ProcessResponse Set Data Message [F0 00 00 70 00 00 7F 00 00 04 02 00 00 07 00 00 01 00 0C 00 00 00 0A 0A 0A 00 0A 01 00 00 00 00 42 F7]
6/25/2017 10:51:58 AM ProcessResponse Zone All Info Response Controller:1 Zone:1
6/25/2017 10:51:58 AM ProcessResponse Zone Power=0
6/25/2017 10:51:58 AM ProcessResponse Zone Current Source=1
6/25/2017 10:51:58 AM ProcessResponse Zone Volume=20
6/25/2017 10:51:58 AM ProcessResponse Zone Bass=0
6/25/2017 10:51:58 AM ProcessResponse Zone Treble=0
6/25/2017 10:51:58 AM ProcessResponse Zone Loudness=0
6/25/2017 10:51:58 AM ProcessResponse Zone Balance=0
6/25/2017 10:51:58 AM ProcessResponse Zone System On State=1
6/25/2017 10:51:58 AM ProcessResponse Zone Shared Source=0
6/25/2017 10:51:58 AM ProcessResponse Zone Party Mode=0
6/25/2017 10:51:58 AM ProcessResponse Zone DND=0
6/25/2017 10:52:13 AM ProcessCommand Cmd=[1~Status~1] Client=[]
6/25/2017 10:52:13 AM TX:1 F0 00 00 7F 00 00 70 01 04 02 00 00 07 00 00 7C F7
6/25/2017 10:52:13 AM ProcessResponse Set Data Message [F0 00 00 70 00 00 7F 00 00 04 02 00 00 07 00 00 01 00 0C 00 00 00 0A 0A 0A 00 0A 01 00 00 00 00 42 F7]
6/25/2017 10:52:13 AM ProcessResponse Zone All Info Response Controller:1 Zone:1
6/25/2017 10:52:13 AM ProcessResponse Zone Power=0
6/25/2017 10:52:13 AM ProcessResponse Zone Current Source=1
6/25/2017 10:52:13 AM ProcessResponse Zone Volume=20
6/25/2017 10:52:13 AM ProcessResponse Zone Bass=0
6/25/2017 10:52:13 AM ProcessResponse Zone Treble=0
6/25/2017 10:52:13 AM ProcessResponse Zone Loudness=0
6/25/2017 10:52:13 AM ProcessResponse Zone Balance=0
6/25/2017 10:52:13 AM ProcessResponse Zone System On State=1
6/25/2017 10:52:13 AM ProcessResponse Zone Shared Source=0
6/25/2017 10:52:13 AM ProcessResponse Zone Party Mode=0
6/25/2017 10:52:13 AM ProcessResponse Zone DND=0
Thanks
Dave Bruner
:shock:

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Russound CAV66 and recent updates

Sun Jun 25, 2017 11:37 am

My mistake. I apologize for that. I added code to turn on the zone if the zone was not already on in the SetSource command and I mistyped one of the command bytes. Fixed now.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3338
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Re: Russound CAV66 and recent updates

Sun Jun 25, 2017 1:05 pm

Ah!! Fat fingers strikes again! Thanks for taking a look and repairing the issue.
Thanks
Dave Bruner
:shock:

User avatar
jwr
Senior Member
Senior Member
Posts: 161
Joined: Sat Oct 25, 2008 12:13 pm
Contact: Send private message

Re: Russound CAV66 and recent updates

Sat Aug 05, 2017 7:12 pm

Glad I found this post... I thought I was losing it. In my zone select logic it calls setsource to initialize all the variables. Now when I change to a different zone it automatically turns it on. Surprise... Is there any way to make this automatic turn on in setsource optional?

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Russound CAV66 and recent updates

Sun Aug 06, 2017 9:59 pm

There is no way to disable that at this point in time. Is an automatic power on on select bad thing?

User avatar
jwr
Senior Member
Senior Member
Posts: 161
Joined: Sat Oct 25, 2008 12:13 pm
Contact: Send private message

Re: Russound CAV66 and recent updates

Mon Aug 07, 2017 2:15 pm

Hey Dave,

There are zones that I have such as my great room and theater where selecting the zone doesn't mean I want to turn on the Russound keypad. There are other AV devices in the zone. With this change, when I watch a movie I have to select the theater zone and then turn off the Russound keypad before starting the movie. Not a huge deal, it would just be nice if there was a way in the setsource call to override it. No issue with the auto on being the default, either a variable or an additional parameter to change the behavior would be nice.

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Russound CAV66 and recent updates

Mon Aug 07, 2017 9:00 pm

Ok, that makes sense. I will add an optional third parameter to the function that can be used to disable the auto power on default. I'll document when the driver gets updated.

User avatar
jwr
Senior Member
Senior Member
Posts: 161
Joined: Sat Oct 25, 2008 12:13 pm
Contact: Send private message

Re: Russound CAV66 and recent updates

Tue Aug 08, 2017 9:18 am

Thanks Dave!

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Russound CAV66 and recent updates

Tue Aug 08, 2017 6:49 pm

I have updated the driver. The SetSource and Switch commands will now accept an optional third parameter "Disable Auto Power On" that accepts a true,false value. It will default false meaning it will automatically power on the zone by default.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3338
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Re: Russound CAV66 and recent updates

Tue Aug 08, 2017 7:08 pm

Good. That fixes an issue in one of my zones as well.
Thanks
Dave Bruner
:shock:

User avatar
jwr
Senior Member
Senior Member
Posts: 161
Joined: Sat Oct 25, 2008 12:13 pm
Contact: Send private message

Re: Russound CAV66 and recent updates

Sat Aug 26, 2017 3:06 pm

Thanks Dave,

Works very well. Sorry for the delay... Finally realized I need to login to the Installer to see changes now.

Return to “A/V Family Device Drivers”

Who is online

Users browsing this forum: No registered users and 9 guests