Art Dustman
Expert
Expert
Posts: 604
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Elk losing comms to Plugin

Fri Apr 26, 2013 3:29 pm

My elk is losing comms with the plugin and driving me nuts wondering why the alarm and stats are reporting wacky things and not following the schedule. I see this in my log

SendCommand - Error at SendCommand at line #661 - The write timed out

Art

User avatar
AllonisDave
Founder
Founder
Posts: 11566
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Elk losing comms to Plugin

Sat Apr 27, 2013 12:53 pm

Line 661 is where it tries to write the string of data to the serial port and then waits for the Elk to send the ACK that it got the command. "The write timed out" is a Windows error message saying that something it wrong with the serial port as the serial driver for the port did not respond to the write request. Can you try a different serial port? What type of serial port is it?

Art Dustman
Expert
Expert
Posts: 604
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Elk losing comms to Plugin

Mon Apr 29, 2013 10:01 am

It's on an edgeport 4 I had lying around. I had an edgeport 16 and two weeks ago windows complained that a USB port exceeded a voltage limit. The edgeport 16 tested dead, along with my USB sound card. Both were replaced with new equipment. I just got an edgeport 12 I have yet to install, and will migrate the Elk to that. I'll check to be sure nothing remains of the old drivers and post back.

Return to “Elk Products”

Who is online

Users browsing this forum: No registered users and 1 guest