Ranger Home Automation
Expert
Expert
Posts: 652
Joined: Tue Jun 26, 2007 11:31 pm
Location: Temple, central Texas
Contact: Send private message

Thermostat thread

Sat Jul 19, 2008 4:56 pm

Cycling thru fan, mode and hold works fine. When the command is sent from ML, it only takes about a second for the command to get to the physical thermostat. THATS GREAT!!

However, to get the update back to the ml screen it never takes less than ten seconds and most of the time it takes about fourteen seconds. Example, turn fan ON:

Physical Fan actually turns on in about one second. WOOHOO!!!
The thermostat GUI wont show ON until after at least 10-14 seconds

(Same with mode and hold)

I assume this is because the "POLL STATUS EVERY" is set to 15 seconds. If I change that to 2 seconds, wont that tax my CPU? Is there a way to have a particular event polled based on the command sent? Meaning if i send a thermostat command have it polled so it reflects immediatly in ML? I am thinking we want to avoid having all status's polled every second or two. PCAccess is pretty immediate.

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Sat Jul 19, 2008 5:21 pm

Your assumptions are correct. I'll add a poll of the tstat immediately after a tstat command in the next release.

Ranger Home Automation
Expert
Expert
Posts: 652
Joined: Tue Jun 26, 2007 11:31 pm
Location: Temple, central Texas
Contact: Send private message

Adjusting Thermostat up or down one degree at a time.

Sat Jul 19, 2008 7:19 pm

Wow, did I actually CONTRIBUTE something finally? :)

I dont see in the Agent where there any commands to incrementally increase the temp up or down one degree at a time. This, of course, is possible via the actual thermostat. Is there proper syntax for it to be done thru ML?

My apologies if this has been addressed already. My search did not yield anything.

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Sun Jul 20, 2008 12:20 am

Version 3.0.3122.38039 of the agent add Inc and Dec functions to Thermostat Heat and Cool setpoints and adds an immediate feedback poll when a TStat or Unit command is issued.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3342
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Sun Jul 27, 2008 10:23 am

Thermostat functions are working well. I still am using a macro to adjust temperature, which actually offers bennifits if communications is lost.

Macro for heat SP Up is;

Macro|
MLMath|Add~HeatSP~{{hai_thermostat001_heatsetpointfround}}~1!
MLServeCmd.MLHAI|001~TStat~1~HeatF~{{HeatSP}}
Thanks
Dave Bruner
:shock:

ricks
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1133
Joined: Wed Oct 27, 2004 8:01 pm
Location: Latham, Massachusetts
Contact: Send private message

Sun Jul 27, 2008 10:49 am

One other odd thing with the tstats is that the options for Hold are Hold and On. Seems to be the same thing.

Rick

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3342
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Sun Jul 27, 2008 11:07 am

Yep - should be ON and OFF

Fan works OK with the options of ON and AUTO
Thanks
Dave Bruner
:shock:

User avatar
AllonisDave
Founder
Founder
Posts: 11497
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Sun Jul 27, 2008 4:26 pm

One other odd thing with the tstats is that the options for Hold are Hold and On. Seems to be the same thing.


Yes, typo on my part, it should be Off and Hold. It's fixed in the next release.

Return to “MLHAI Beta”

Who is online

Users browsing this forum: No registered users and 1 guest