User avatar
cborod
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1212
Joined: Fri Oct 07, 2005 6:26 pm
Location: Mount Gretna, PA
Contact: Send private message

Release Candidate 09/28/06

Fri Sep 29, 2006 6:53 am

First impression is BINGO!

Huge leap forward! Love the improvements. Right on the money!

Still does not play well with the Theater Tek plugin. Now cannot coexist at all.

New "wrinkle" HAI plugin does not allow startup or stop/restart while MLServer is running. It used to complain (log entry) but worked in prior versions. Now it must start with MLServer startup.

Don't want to blame the MLHAI plugin, because I am running on a newly installed system but when MLHAI is running AND all other plugins are running (exception MLDeviceMgr and TT) I am getting consistent MLServer crash within minutes.

Haven't confirmed if it is HAI logging, the plugin itself, interaction with other components. Just want you to be aware.......

On the surface however, this version delivers much more of what I hoped for!

Agree that changes to HAI internal workings should not be part of the plugin scope! Leave that to HAI software.

More and logs if necessary as the day progresses.
ChrisB


___________________________________
"Round up the usual suspects."

User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 4:24 pm
Contact: Send private message

Fri Sep 29, 2006 8:42 am

Looking Good!

A few observations.

1. When running setup in the plugin I still get 39 auxillary temp monitors created, one for each zone I have in the panel.

2. Getting the following error on startup:

Code: Select all

9/29/2006 7:53:46 AM Error MDIForm_Load Calling DoStartup for MLHAI Error# 438 - Object doesn't support this property or method raised by MDIForm_Load Calling DoStartup for MLHAI
Not sure what it means...

3. X10 polling still kills the TSTATs. Will PM contact to you.

4. Not seeing MLHAI_MESSAGE_1 variable? Seeing phone, armevent, armcode and AC status

5. Regarding armevent, ac, and other panel status variables...suggest gettin a time stamp for the last change. Very handy

6. The new naming scheme is great

7. Cleanup of the variable states looks GREAT....with one exception. HOLD now reads "NOT HOLD" when off and "HOLD" when on. I would recommend changing that to OFF and ON respectively.

8. Hang on server exit problem resolved.


Barry

User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 4:24 pm
Contact: Send private message

Fri Sep 29, 2006 9:12 am

I seem to be seeing some instability with this update too. Multiple crashes in the couple of hours or so it has been running. I haven't been able to pin a crash to a specific event but they are numerous and started with installation of this version. Also, this update seems to be more resource hungry. Running remotely now so I can't see performance monitor.

Barry

User avatar
DavidL
Founder
Founder
Posts: 11563
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Fri Sep 29, 2006 10:41 am

ChrisB, what version of MLServer? Upgrade to the very latest.
Please try to isolate what plugins may be causing the crash. You can do this be deselecting the plugins (get rid of half) and then restarting MLServer to test. The problem is with combinations (like TT and HAI), that you might get rid of one, but not the other in the half life approach.

I have noticed same error message in MLServer log. That will be fixed, and it might have something to do with any instability issues. this was a new feature where the MLServer now tracks what plugin is launched and then notifies those plugins to shut down when MLServer shuts down. I have also seen MLServer error on shutdown, which is probably related to the launch error.

Regarding licensing, we now are taking orders for the MLHAI plugin:
www.cinemaronline.com/mlserver.mlhai.html
We will fix the instability and launch error problems. That's a promise. Rest of comments will likely be addressed, but no promises. We too want this to be a very powerful asset, but can't commit until we uncover what the additions will take in resources. X10 / Thermo polling has us scratching our heads, so no commit on that one, but we know it's important. Just hard to commit until we see what's up.

thanx for the great beta test results. As you can see, your voices are heard and are being implemented.

User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 4:24 pm
Contact: Send private message

Fri Sep 29, 2006 11:39 am

Ouch...$99.99 :shock: Not even a introductory price?

B

User avatar
cborod
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1212
Joined: Fri Oct 07, 2005 6:26 pm
Location: Mount Gretna, PA
Contact: Send private message

Fri Sep 29, 2006 12:16 pm

Server 97


I have done the coexistence thing. Up to this beta it has definitely been interaction between TT and HAI. I have done different machines, different configurations but it ALWAYS happens with TT load then HAI load.

Prior to this HAI beta I could load server with TT and then manually load HAI and have peaceful running. That is no longer possible since HAI does not stop/startup when Server is already running. Most other plugins allow stop/start/restart hot.

The runtime error appears and reports TT as the offending application. Then runs through a series of other runtime errors. At that point the TT applet becomes unusable. Any attempt to use it locks the device manager on the screen and can only be cured with a MLServer stop/restart. That's why I originally reported it over at the TT beta thread (complete with screens and logs)

If I run MLserver with all plugins and TT with no HAI.....all is fine.
If I run MLserver with all plugins at HAI with not TT.......all is fine.

No other plugin has errors or appears to interfere. I can add/remove various plugins....the error ONLY ocurs when TT and HAI are trying to run simultaneously.

I allowed system and TT to run all night and today with no errors up to now. I will switch to HAI and no TT to see if the server crashes return. Last night with all plugins and HAI (no TT) server would not run more than 5 minutes without crash.

At work now.....won't be able to tell more until tonight.
ChrisB


___________________________________
"Round up the usual suspects."

User avatar
DavidL
Founder
Founder
Posts: 11563
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Fri Sep 29, 2006 3:21 pm

mjunky,
$99 is the same price that the ELKM1 plugin cost. We have spent multiples of monies more on development of the HAI plugin (and continue to do so). So, instead of raising the price, we kept it were the ELK M1 plugin has been successfully been selling.

User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 4:24 pm
Contact: Send private message

Fri Sep 29, 2006 7:22 pm

Understand that you need to make money on your investment. Would just point out that the HS plugin is $40. I'll certainly be investing in your product but I would be surprised to see to many converts at you current pricing.

Barry

User avatar
cborod
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1212
Joined: Fri Oct 07, 2005 6:26 pm
Location: Mount Gretna, PA
Contact: Send private message

Fri Sep 29, 2006 9:02 pm

Okay...I am over half way through the plugins.....at this time MLLighting and MLHSPlugin and ML Device manager repeatedly do not get along with MLHAI.

Most predominate error is Runtime 438 and Runtime 404 (not web 404)as well as other errors that report the "callee has disappeared"..cover the screen like a solitaire winner......None of these appear in system or application logs, do not appear in verbose MLServer logs, and unfortunately they occur in ways that make screen shots impossible. My son has the digital camera or I could shoot with that......BUT

My "elementary Watson" sense is telling me......maybe there is a code library in use as well as in the MLLighting/Insteon and TT and HAI?? Are many programs hitting the same tool or library....?
ChrisB


___________________________________
"Round up the usual suspects."

dr.frazier
Senior Member
Senior Member
Posts: 224
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Sat Sep 30, 2006 12:28 am

Can't get completely into the program because it says my 30 day trial is over. I guess that was the reason for the end of beta testing? However, I still get my smtp error on startup and shutdown error hanging the system. I still get random thermo zones loaded as well as all of my aux temp zones become populated. The only thing I can't do is poll and set variables. Maybe this willl clear when I activate. Time to go pony up and activate. I was excited about the release notes and hope it lives up to expectations.

Randy

dr.frazier
Senior Member
Senior Member
Posts: 224
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Sat Sep 30, 2006 12:29 am

Also getting error #2 Barry describes above.

Randy

User avatar
cborod
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1212
Joined: Fri Oct 07, 2005 6:26 pm
Location: Mount Gretna, PA
Contact: Send private message

Sat Sep 30, 2006 8:07 am

My test machine MLHAI has expired. That leaves me with trying to test on my production environment.....which won't work because MLHAI doesn't play well with other plugins.

I've placed my order as a willingness to fund the beta so we end up with a functional plugin.....

Testing paused until this gets resolved......
ChrisB


___________________________________
"Round up the usual suspects."

dr.frazier
Senior Member
Senior Member
Posts: 224
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Sun Oct 01, 2006 10:10 pm

Have licensed my hai plugin and now testing further. Agree that variables much better organized and named. Compose lighting is better. Will PM specifics. Can now control lighting, feedback needs a little work. Still crashes, however. Startup has previous message. The crash message is

Error SendIt Error# -2147417848 - Automation error
The object invoked has disconnected from its clients. raised by SendIt

SMTP message no longer present. Still records all 39 aux zones.

On the right track. Still need to make it quicker or be able to isolate units to sub out so to speak the lighting end.

Randy

dr.frazier
Senior Member
Senior Member
Posts: 224
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Sun Oct 01, 2006 10:15 pm

Forgot-- Hats off to Raj indeed.

Also do not see a MLHAI_MESSAGE_1 variable.

Randy

User avatar
cborod
Is there life beyond myServer?
Is there life beyond myServer?
Posts: 1212
Joined: Fri Oct 07, 2005 6:26 pm
Location: Mount Gretna, PA
Contact: Send private message

Mon Oct 02, 2006 8:55 pm

I can now repeat some specific errors with specific conditions that allow the majority of MLServer to load before crashing...

theaterTekController Run-time error '10037': The operation is completed. No blocking

operation is in progress.

MLHSPlugin Run-time error '440' Automation Error

MLDeviceManager Run-time error '-2147418105 (90010007)': Automation error
The calledd (server[not server application]) is not available and disappeared; all

connections are invalid. The call may have executed.....

lost the rest of the message when MLServer crashed.

At the time of the error message, this appears in MLServer log

10/2/2006 8:47:22 PM Error MDIForm_Load Calling DoStartup for MLHAI Error# 438 - Object doesn't support this property or method raised by MDIForm_Load Calling DoStartup for MLHAI

Then it crashes.

I cannot prevent a crash unless I unload MLHAI.

Previous versions of MLHAI plugin would allow me to run MLHSplugin.....definitely never TheaterTek/Device Manager.
ChrisB


___________________________________
"Round up the usual suspects."

Return to “MLHAI Beta”

Who is online

Users browsing this forum: No registered users and 2 guests